Parece que tu instalación de PHP no tiene la extensión MySQL que WordPress requiere.